在vista下安装帝盟S70,S100,MX400驱动,重启后驱动不再丢失!  2008-12-29
(vista里声卡驱动重启后丢失通用解决办法)----->同样适合windows7安装
返回上一页 声卡收藏图片 显卡收藏图片 老卡驱动下载 常用工具软件 硬件收藏人物 关于影子传说 网上好文转载
 

    自帝盟S90(AU8820芯片)和帝盟MX300(AU8830芯片)在Vista成功安装后(见本站影子原创文章有图文详解),如何能够正常使用ESS芯片的三张帝盟声卡,S100,S70,MX400,就成了我的一块心病,熟悉影子的人,都知道我最爱帝盟的S100功放版,无奈比尔盖茨这次推出的VISTA系统,让我欢喜让我忧啊!尽管S100使用安桥SE120的驱动或其他XP修改版驱动都可安装在VISTA上,但是,有个致命的缺点,就是不能重新启动系统,只要一重启,驱动就会丢失,入系统后又要再重新安装驱动一次,真是烦恼!S70,MX400也出现了相同的情况,不光如此,发现众多网友手上的老声卡也患了"重启就会没声音"!抑郁的年代啊!难道我等要放弃老卡,使用板载?于是上网寻求妙方,得到cwfriend兄的神方(此法是他的原创),终于解决这一疑难杂症,下面影子以帝盟S100功放版为例子,图文并貌详细和大家分享成功的喜悦。万分感谢cwfriend 兄!

先说一下影子的测试装备:富士康A690G ,AMD黑5000+,2G的kingmax 完美32位VISTA+SP1版, 

MSI G41 ,E5200,2G,Win7 RTM

测试的声卡有:帝盟S100功放版,非功放版,S70全金手指和缺金手指,MX400,合共5张声卡!

要使用到的文件有2个:微软官方devcon.exe和系统服务添加器srvinstw,还有vista里可使用的S70,S100,MX400的3个驱动。

这"2个工具"+"3个驱动"一次打包下载

共4招!就可以解决重启后驱动丢失的老问题!

第1招:把"devcon.exe"复制到C:\windowns\system32 ,
把"srvinstw,还有vista里可使用的S70,S100,MX400驱动"复制到C盘根目录:

copydevcon.jpg (123408 字节)

copy4.jpg (98356 字节)

然后关机,插入帝盟S100功放版,vista找到新硬件,并要求为S100安装驱动,这时我们把驱动指向刚复制到C盘里的ONKYO SE-120PCI驱动

setup1.jpg (141642 字节)

setup2.jpg (137088 字节)

第2招:把devcon.exe添加为系统服务,步骤如下

 鼠标右键"以管理员身份运行"SRVINSTW.EXE----->安装服务---->本地机器----->在"服务名称"里填写AudioReset----->点击"浏览"找到 C:\windows\system32\devcon.exe----->,然后就一直点"下一步"直到"完成"后程序自动关闭!

setup3.jpg (121186 字节)

 

setup4.jpg (186186 字节)

setup5.jpg (183095 字节)

第三招:进入注册表,找出AudioReset,修改2个值,ImagePathErrorControl 步骤如下:

开始---->运行---->regedit--->HKEY_LOCAL_MACHINE--->SYSTEM--->ControlSet001---->Serives--->AudioReset
右边找到2个我们要修改的值:ImagePathErrorControl 

regedit1.jpg (175499 字节)

先修改ImagePath值,在原来 C:\windows\system32\devcon 的后面,添加空格restart空格您的声卡硬件ID

使ImagePath值变成 C:\windows\system32\devcon空格restart空格您的声卡硬件ID

regedit2.jpg (93377 字节)

怎么才能知道"您的声卡硬件ID"呢?请到"设备管理器"---->"声音,视频和游戏控制"下(声卡驱动)--->详细信息--->属性--->硬件ID

(因为不同的声卡硬件ID是不一样的,大家各自找吧!很简单的,一看就懂了)

(以下是我的帝盟S100功放版的硬件ID)

regedit3.jpg (97779 字节)

找出"您的声卡硬件ID"后,用鼠标右键复制到ImagePath值 C:\windows\system32\devcon后

如我的S100硬件ID复制后,就是 C:\Windows\System32\devcon.exe restart PCI\VEN_125D&DEV_1988&SUBSYS_41001092&REV_10

regedit4.jpg (177991 字节)

然后再修改ErrorControl值为0(运行这个服务一定会报错,这样可以避免写入日志)

regedit5.jpg (126681 字节)

第四招:测试设置的正确性,步骤如下:
开始---->设置---->控制面板----->管理工具----->服务----->找到"AudioReset",然后点选"启动此服务"。

tool1.jpg (191337 字节)

马上就会收到"Windows无法启动AudioReset服务(位于 本地计算机上),错误1053,服务没有及时响应启动或者控制请求"!

这就说明您已经成功!

tool2.jpg (101502 字节)

tool3.jpg (109081 字节)

OK,选择"重新启动",试试看,哈哈。。。。声音回来了!爽啊!

     影子花了一个月的时间反复ghost Vista 13次,试验了这5块声卡,反复重启,反复关机开机,驱动都不再丢失,一切正常!绝对是现在vista里唯一的解决声卡驱动重启丢失的方法!强烈的推荐大家使用这个方法!
        按照cwfriend兄所述的,适合一切重启后驱动丢失的声卡,但是,有一个大的前提,就是您的声卡,一定要在VISTA里有驱动(换句话说就是在VISTA里能够正常使用的),如果声卡没有VISTA驱动,一切都是白说白做!敬请大家注意!

    安装的过程中要特别注意的地方是:在注册表里的"ImagePath值"后添加(您的声卡硬件ID),这个"声卡的硬件ID",大家要在正常安装了声卡的驱动后,到"设备管理"------>"声音,视频和游戏控制"中找,然后---->详细信息---->属性---->硬件ID,第一个项目就是!然后使用鼠标右键复制,再粘贴到"ImagePath值"后,重中之重要记得,在"ImagePath值"后是--->空格restart空格(也就是说在restart的左右都要空格)

 

    在这里。列举我试验的S70,S100和MX400的硬件ID,供大家参考一下,值得一提的是,S70全金手指版和缺金手指版的硬件ID是不同的,我在一次试验里,先是安装上S70全,然后再安上S70缺,VISTA居然出现蓝屏,然后再重装vista试,发现原来这2个版本的S70的硬件ID是不同的!这点大家要注意,不要偷懒,每次换卡后,最后都再复制"声卡的硬件ID"到ImagePath值"里!而S100的2个版本,硬件ID是相同的!没有出现蓝屏。

         敬请大家特别注意帝盟MX400,以往发现它和NF2的主板有兼容性的问题,现在我也发现它和AMD的双核主板,如:A690G,A780G,A790G,A785G...等有兼容性的问题,症状表现为"能够正常安装驱动,但是无法发出声音",Windows XP系统是这样,Vista/Win7同样是出现这样的问题!看来MX400和AMD的双核主板没有缘分了。(望各大高手出手相救!致谢!QQ:50410629 影子传说)

s70all.jpg (122161 字节)

s70que.jpg (117977 字节)

 

mx400.jpg (184741 字节)


S70全金手指版硬件ID

PCI\VEN_125D&DEV_1968&SUBSYS_0001125D&REV_00
-----------------------------------------------
S70缺金手指版硬件ID

PCI\VEN_125D&DEV_1968&SUBSYS_00000000&REV_00
-----------------------------------------------
S100功版版和非功放版硬件ID

PCI\VEN_125D&DEV_1988&SUBSYS_41001092&REV_10
-----------------------------------------------
MX400的硬件ID

PCI\VEN_125D&DEV_1978&SUBSYS_40001092&REV_10

代表受惠于此良方的网友们向cwfriend兄表示最衷心的感谢!

(注:此方为cwfriend兄原创,原文如下图,影子只是照方拿药,药到病除啊!)

cwfriendidea.JPG (342809 字节)

    原本以为这次VISTA出来后,老卡遇到这样的情况,全部都完蛋了,2008年里完美安装S100的驱动,是梦一场,哈哈!好在,有此良方,终于都能够在2008年终结时,了结这庄烦心事!就这样,除了帝盟MX200不能在2k,xp,VISTA里使用外,其他全部帝盟声卡(s70,s90,s100,mx300,mx400)都可以正常使用在vista里!实在是太爽了。.。

之后,受windows7 beta版推出的影响,也跟随主流,第一时间下了一个32位版本的windows7来试验一下,诚如所想,windows7只是vista的升级加强版,在vista里适用的声卡驱动和方法,在windows7里。同样是可行的!没有任何问题。于是,影子在windows7使用同样的安装的方法,顺利安装好了S70,S100,MX400的驱动,重启后,驱动也不会丢失!真的很不错!下面是3张声卡上windows7的截图,大家只要安装上述的方法安装,就OK 了!

s70inwindows7.jpg (213672 字节)
S70在windows7里
S100inwindows7.jpg (217446 字节)
S100在windows7里
mx400inwindows7.jpg (219304 字节)
MX400在windows7里
 
QQ:50410629 影子传说  Email:ssstjy@163.com 欢迎大家访问我的个人网站 www.ssstjy.com